Email delivery delayed

Minor incident Registration Services
2023-02-28 14:41 EST · 2 hours, 11 minutes

Updates

Resolved

We have confirmed that emails are now delivering as normal.

February 28, 2023 · 16:53 EST
Update

SMTP has notified us of a fix. We are still monitoring the situation, however emails are sending but delayed.

February 28, 2023 · 16:41 EST
Monitoring

Email service provider SMTP.com is down. Please see https://status.smtp.com/ for details.

February 28, 2023 · 14:46 EST

← Back